Access Keys:
Skip to content (Access Key - 0)

QuarkXPress to App Studio

Get started

  • You need to be using QuarkXPress 10 or later.
  • For QuarkXPress users on an earlier version of QuarkXPress, please visit the Quark Store to purchase an upgrade.
  • Should you happen to be brand new to QuarkXPress, Quark has a free Test Drive version you can download for Mac and Windows

Create your content

For a more detailed description of the functionality in App Studio in QuarkXPress, please consult the QuarkXPress App Studio Guide on the Downloads page. It's also located in the the Documents folder in the QuarkXPress application folder on your computer.

The basic App Studio publishing process involves the following steps:

  1. Launch QuarkXPress 10 and create a new App Studio layout by choosing File > New Project, then set the Layout Type to App Studio and accept the defaults (iPad vertical and horizontal, OS Bar checked).You should create a separate QuarkXPress project file for each section of your publication.
  2. Design your pages. App Studio uses HTML5 to describe the contents and layout, including HTML descriptions of your text boxes. Since HTML has fewer text formatting options than QuarkXPress, some attributes are disabled by default. You can expose all of the text formatting attributes available in QuarkXPress by checking the Con- vert to Graphic on Export option on the Measurements palette or Modify dialog box. Try designing both a vertical and horizontal version of each page 
  3. Add interactivity and multimedia by creating overlay boxes or tagging your layout boxes directly. Add interactivity to a box by selecting a behavior from the new HTML5 palette, available under the Window menu.
  4. Upload your article to the Publishing Portal by opening the App Studio Publishing palette (available under the Window menu), entering your account credentials (from the account you created on the publishing portal, selecting the issue you want to upload to, entering an Article Name, and then clicking the Upload button. Once the upload is complete you can open the issue in the portal by clicking the View Online button.

The next step is to Test and Preview your content.

Adaptavist Theme Builder (4.2.1) Powered by Atlassian Confluence 3.5, the Enterprise Wiki